Back to overview
Downtime

DNS Issues with Ascendara's domain

Oct 29 at 05:14am HDT
Affected services
Ascendara Webpage
Large File Provider
Ascendara Storage

Resolved
Oct 29 at 12:12pm HDT

The issue with the domains have been identified and was not an issue with Cloudflare. All sites are recovering and will be back online.

Created
Oct 29 at 05:14am HDT

Cloudflare services are under maintenance and some services routed through Cloudflare may not work.